
 Radio Museum Handbook  
August 7, 2018 

 

 - 24 -  
 

6 How to format a schematic 

6.1 FAQ regarding schematics 

Before discussing the schematic formatting procedure, here are questions that are frequently 
asked: 

  

a) How should I set my scanner settings when scanning schematics? 
I. SCANNER RESOLUTION - Please set your resolution to be 300 DPI (Dots Per Inch) or 

higher.  For most schematics, 300 DPI is sufficient.  For small schematics or for schematics 

with small text, use 400 DPI or 600 DPI. 

II. IMAGE TYPE – Please scan as “Gray scale”.  Do not scan as “Color” or “Black & White”. 

III. IMAGE FORMAT SAVED – Please save the image as a “TIFF” file so that the file extension 

is *.tif.  

 

b) What data or information should be formatted and uploaded as a schematic 
(as opposed to being uploaded as a picture)? 

In general, pictures and sales literature should be scanned, formatted and uploaded as pictures.  
Most other material should be scanned, formatted and uploaded as a schematic.  This includes 
schematics, alignment instructions, parts lists (or BOMS’ – Bill Of Materials), operation manuals, dial 
cord drawings, PCB layouts, wiring diagrams, mechanical drawings, descriptions, and any other 
material that contain mostly schematics or text.   

 

c) What if schematics of the model already exist on the model page? 

We welcome and encourage members to upload additional schematics to models if the existing 
schematics have poor quality or if the existing schematics come from a different source.  So for 
example, if the existing schematics came from a “Riders” manual, and you have the schematic 
from a radio manufacturer manual, we encourage you to scan, format and upload the manufac-
turer schematic to the radio model page also. 

Before uploading schematics to Radio Museum, the schematics must be formatted using image 
processing software.  Formatting is required so that a high-quality schematic is created and has a 
small file size.  There are 8 steps in preparing a schematic.  The procedure below uses the 
IRFANVIEW imaging software.  A free download is available from:  http://www.irfanview.com/ .   
The Irfanview software version used in the examples below is version 4.50, however this proce-
dure will work with other versions also. 

Once you have Irfanview installed on your computer, you can begin the formatting process. 

 

NOTE: Please follow these instructions in the sequence given!!  Not follow-
ing the given sequence will create schematic files that are too large or do 
not have good quality!! 

http://www.irfanview.com/
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6.2 Formatting a schematic using Irfanview 

6.2.1 Installing Irfanview 

Before uploading schematics to Radio Museum, the schematics must be formatted using image 
processing software.  Formatting is required so that a high-quality schematic is created and has a 
small file size.  There are 8 steps in preparing a schematic.  The procedure below uses the 
IRFANVIEW imaging software.  A free download is available from:  http://www.irfanview.com/ .   
The Irfanview software version used in the examples below is version 4.50, however this proce-
dure will work with other versions also. 

Once you have Irfanview installed on your computer, you can begin the formatting process. 

NOTE: Please follow these instructions in the sequence given!!  Not follow-
ing the given sequence will create schematic files that are too large or do 
not have good quality!! 

6.2.2 Schematic Format Procedure using Irfanview 

Below are the 8 steps in preparing a schematic: 

 

1) LOAD THE SCHEMATIC 

 
a. Start Irfanview, then select “Open” from the “File” pull-down menu. 

 

 

Figure 6-1: Opening a file in Irfanview 

http://www.irfanview.com/
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b. In the pop-up window, select the schematic file you want to format by double clicking on 

the file name.  The schematic will appear in Irfanview.  If the schematic is too large or 

small, you can adjust the size of the schematic by going to the “View” pull-down menu, 

selecting “Display options”, then selecting “Fit images to window”.  The complete 

schematic should then show in the window. 

 

 

Figure 6-2: Selecting a file to open in Irfanview 

 

 

Figure 6-3: Schematic file opened in Irfanview 
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2) ROTATE THE SCHEMATIC (If Required) 

 

a. The schematic should be in portrait mode and should not be upside down.  If the 

schematic needs to be rotated, select “Rotate Right (clockwise)” from the “Image” 

pulldown menu. If necessary, repeat this procedure until the picture is in portrait mode 

and is not upside down. 

 

Figure 6-4: Schematic rotated to Portrait view 
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b. The schematic should be aligned in the window.  If the schematic is NOT aligned in the 

window (See picture below), then align the schematic by selecting the “Custom/Fine 

rotation”, then type in the fine angle to align the schematic.  Usually only a fraction of a 

degree is required (Example: 0.4).  Positive numbers rotate the schematic clockwise, 

negative numbers rotate the schematic counter-clockwise. 

 

Figure 6-5: Schematic that requires fine rotation 

 

Figure 6-6: Fine rotation window 



 Radio Museum Handbook  
August 7, 2018 

 

 - 29 -  
 

 

3) CROP THE SCHEMATIC 

 
a. Place the mouse pointer somewhere in the upper left side of the schematic, then while 

holding down the left mouse button, move the mouse pointer to the lower right side of the 

schematic, then release the left mouse button.  You will now see a rectangle drawn on 

the schematic.  You want this rectangle to contain just the complete schematic, so adjust 

the rectangle as required by placing the mouse pointer over one side of the rectangle 

line, then while holding the left mouse button down, you can move the side of the 

rectangle until you are near the edge of the schematic itself, then release the left mouse 

button.  (The rectangle can be removed by clicking outside of the rectangle).  Do this for 

all 4 sides of the schematic.  The rectangle should look like the picture below when you 

are finished. 

 

b. While holding the “Cntl” key, hit the letter “Y”, then release both keys.  The schematic 

should now be cropped to within the rectangle window.  (You can also use the “Cut – 

Area outside of the selection” option in the “Edit” pull-down menu to perform the same 

action).  If you are not happy with the result, select “Undo” from the “Edit” pulldown menu 

and try again. 

 

 

Figure 6-8: Schematic after cropping 

 

Figure 6-7: Drawing box around the schematic 
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4) ADJUST DIMENSIONS OF SCHEMATIC 

a.  The schematic size should be set for a 27 cm height. Select the “Image” pull-down menu 

and click “Resize/Resample”: 

 

 

Figure 6-9: Resize Schematic option in Irfanview 

 
b. The “Resize/Resample image” window will appear with the schematic size information.  

Make sure that “cm” is selected for the units and also that the “Preserve aspect ratio 

(proportional)” option is selected.  Type in “27” for the Height.  If you have scanned the 

schematic at some higher resolution than 300 DPI (such as 400 or 600 DPI), then type in 

“300” for the DPI.  When finished, hit the “OK” button. 

 

 

Figure 6-10: Resize/Resample image window 
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5) DECREASE COLOR DEPTH OF SCHEMATIC 

a. The number of colors used in the schematic needs to be reduced.  Select “Decrease 

Color Depth…” from the “Image” pulldown menu. 

 

 

Figure 6-11: Decrease Color Depth option in Irfanview 

 

b. The “Decrease color depth” window will appear.  Select the “Custom” option and type in 

“4”.  Make sure that the “Use Floyd-Steinberg dithering” option is NOT enabled.  When 

finished, hit the “OK” button. 

 

Figure 6-12: Decrease color depth window 
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6) ADJUST SCHEMATIC COLORS 

 
a. Select “Color corrections…” from the “Image” pulldown menu. 

 

 

Figure 6-13: Color Corrections option in Irfanview 

 
b. The “Color corrections” window will appear.  The goal is to adjust the contrast and 

gamma correction controls so that the background is a clean white color and the 

schematic lines are deep black and solid.  In most cases, setting the “Contrast” to “77” 

and the “Gamma correction” to 0.46” gives very good results.  Leave the “Saturation” 

value at “0”.   

 
Click the “Apply to original” button, which will apply the changes to the full size schematic 
and allow you to see the results of the adjustments.  It is sometimes necessary to set the 
Contrast and Gamma correction values to different values in order to get a good quality 
schematic.  You can re-adjust the values and then click the “Apply to original” button 
again to review the result.  When finished, hit the “OK” button.  
 

 

Figure 6-14: Color Corrections window 
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7) SET SCHEMATIC BACKGROUND TO WHITE  

 

a. Select “Palette” from the “Image” pull-down menu, then select “Edit palette…”. 

 

Figure 6-15: Palette option in Irfanview 

 
b. The “Palette entries” window will appear.  Double click on the lightest color that is shown. 

 

 

Figure 6-16: Palette Entries window 

 



 Radio Museum Handbook  
August 7, 2018 

 

 - 34 -  
 

c. The “Color” window will appear.  Click the White square in the lower right corner.  Then 

click “OK”.   

 
In the “Palette entries” window, click “OK”. 

 

 

Figure 6-17: Color window 
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8) SAVE SCHEMATIC FILE AND CHECKING FILE SIZE 

 
d. To save the schematic, select the “Save as..” option from the “File” pull-down menu. 

 

 

Figure 6-18: Save As option in Irfanview 

e. The “Save Picture As..” pop-up window appears.  Select the location (folder) where you 

want to save the schematic in the “Save in:” pull-down menu.  Select the “PNG – Portable 

Network Graphics” option from the “Save as type:” pull-down-menu.  Then type in the 

name of the schematic file into the “File name:” pull-down menu (See file naming 

convention below).  When finished, hit the “Save” button. 

 
f. The file name (naming convention) must follow the following specific format: 

 
Country Code_Manufacturer_Model#_Document Type.png 
(The .png suffix gets added automatically) 
 
Here are examples of file names: 

usa_FairbanksMorse_57T0_sch1 = complete SCHematic 
usa_FairbanksMorse_57T0_sch2 = another complete Schematic 
usa_FairbanksMorse_57T0_sch1a = left hand part of a divided Schematic 
usa_FairbanksMorse_57T0_sch1b = right hand part of a divided Schematic 
usa_FairbanksMorse_57T0_align = Alignment 
usa_FairbanksMorse_57T0_cord = Cord stringing 
usa_FairbanksMorse_57T0_lay = Print layout, also 1, 2, ... 
usa_FairbanksMorse_57T0_prts = Parts list, also 1, 2,...(C + R) 
usa_FairbanksMorse_57T0_spare = Spare parts 
usa_FairbanksMorse_57T0_descr = Description, also 1, 2, .... 
usa_FairbanksMorse_57T0_titl = Title page of Service manual (with picture) 
usa_FairbanksMorse_57T0_data = Data (e.g.Tube lineup etc.), no picture 
usa_FairbanksMorse_57T0_pos = Position plan (of components), also1, 2, .... 
usa_FairbanksMorse_57T0_wire = Wiring 
usa_FairbanksMorse_57T0_mech = mech drawing, exploded view,etc., also 1, 2, ... 
usa_FairbanksMorse_57T0_misc = Miscellaneous, (try to avoid please) 
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Figure 6-19: Save Picture As window 

 

g. The file size must be less than 600KB.  Using Windows Explorer, navigate to the 
directory where the schematic was saved.  Change the view to “Details”, which will then 
show the size of the files listed in the directory.  The file size of the saved schematic 
should be less than 600KB. If the procedure listed above was followed, the file size 
should be well under this file size. 
 
Even when the procedure is followed, there will still be some cases where the file size will 
be above the 600KB limit. Chassis views are examples of files that may exceed the file 
size (See example below).  Try using the following techniques to reduce the file size: 
 

• When adjusting the schematic colors, try using different values for Contrast and 
Gamma Correction 

• When decreasing the color depth, try using a smaller number of colors 

• If all else fails, setting the DPI to less than 300 when adjusting the dimensions of 
the schematic will further reduce the file size.  Setting the DPI to 200 almost 
always works. 
 

 
 
 


