radiomuseum.org

 
Please click your language flag. Bitte Sprachflagge klicken.

Frage: Schaltnetzteil (SMPS) B&O defekt? Schaltplan?

Moderators:
Martin Renz Ernst Erb Vincent de Franco Martin Bösch Mark Hippenstiel Bernhard Nagel 
 
Please click the blue info button to read more about this page.
Forum » Radios and other type of sets (Physics) etc. » RADIO MODELS DISPLAYED » Frage: Schaltnetzteil (SMPS) B&O defekt? Schaltplan?
           
Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
29.Mar.17 14:31
Reply  |  You aren't logged in. (Guest)   1

Hallo Radiogemeinde,

mein BeoSound 1 hat ein Problem im Schaltnetzteil (SMPS). Es sind keine Ausgangsspannungen messbar. Leider ist von B&O kein Schaltplan zu bekommen (soll es nicht geben!). In den Reparaturhandbücher von B&O heißt es außerdem: "Bei Defekten werden die kompletten Module getauscht!". Das ist ganz schön bitter. Das Einzige was ich dem Repair Manual entnehmen konnte, war ein Blockdiagramm:

Inzwischen ist, dank an die Admins, das Modell hier eingestellt. Ich habe Fotos vom Schaltnetzteil gemacht und hochgeladen. Hier fehlt mir ein wenig die Erfahrung.

  1. Ich finde auf der Platine keinen "Startwiderstand" wohl aber ein IC TNY253G. Übernimmt dieses IC den Startvorgang?
  2. Die bekannten Power ICs (z.B. UC3842) sind ebenfalls nicht auf der Platine. Ich finde aber ein IC L6598.
  3. Als (Doppel-)MOSFET dienen die P6NB50
  4. Kann die Platine für sich alleine geprüft werden oder benötigt das SMPS eine Last am Ausgang um geprüft zu werden.

Derzeit bin ich dabei, einen Schaltplan für das Netzteil zu zeichnen. Leider ist es sehr aufwändig und benötigt noch eine Menge Zeit. Ist vielleicht jemand in der Gemeinde, der bereits einen Schaltplan dieses Netzteils vorliegen hat?

Die bislang von mir geprüften, teilweise ausgebauten Bauteile, waren ohne Befund.

Hier die vorhandenen Bauteile:

Danke schonmal vorab an alle Leser

M.Ruhe

This article was edited 29.Mar.17 14:34 by Michael Ruhe .

Georg Richter
Georg Richter
Editor
D  Articles: 837
Schem.: 83
Pict.: 569
29.Mar.17 22:03
Reply  |  You aren't logged in. (Guest)   2

Sehr geehrter Herr Ruhe,

aus gutem Grund wird allgemein empfohlen, defekte Schaltnetzteile als Ganzes zu ersetzen.

Bei dem gezeigten Netzteil (offensichtlich ein Zulieferteil) ist der TNY253 das "Herz" der Schaltung und erzeugt u.a. die Schaltfrequenz. 44 kHz.  Das IC enthält auch einen Power-MOSFET, Überwachung der inneren Temperatur und Abschaltung bei Unterspannung. Der Hersteller nennt das Teil TinySwitch und preist es für Low-Cost Schaltnetzteile an.

Der L6598 ist ein "Low Voltage Resonant Controller"  welcher die beiden Power-MOSFETs ansteuert wenn die Bedingungen erfüllt sind. Auch dieser mit Unterspannungsabschaltung, zusätzlich Anlaufstrombegrenzung und einem "Abschaltpin".

Der rote Kreis zeigt den Optokoppler welcher die Rückkoplung an einen Eingang des L6598 liefert.

In der Regel wird nur eine Spannung (5V?) wirklich geregelt,die anderen Spannungen werden davon mehr oder weniger genau abgeleitet (keine Lastregelelung).

Auch bei diskreter aufgebauten Schaltnetzteilen benötigt man idealerweise den vollständigen Schaltplan - und eine gewisse Erfahrung.

Sie können mit einem Oszilloskop an allen Spannungsausgängen prüfen ob das Netzteil zyklisch (im Millisekundenbereich) versucht anzulaufen. Manche Schaltnetzteile benötigen auch eine Grundlast an der Hauptspannung.

Wenn das Netzteil noch zyklisch Lebenszeichen von sich gibt können Sie versuchsweise alle Elkos und den Optokoppler ersetzen. Aber ACHTUNG: NETZSPANNUNG !!!

Sie sollten in Ihrem Umkreis eine mit Schaltnetzteilen erfahrene Person zu Rate ziehen.

Datenblätter für die beiden ICs schicke ich Ihnen per eMail.

Freundliche Grüsse,

GR

Mario Tieke
Mario Tieke
Editor
D  Articles: 185
Schem.: 45
Pict.: 58
29.Mar.17 22:50
Reply  |  You aren't logged in. (Guest)   3

Bei diesem Netzteil hamdelt es sich um ein doppeltes Netzteil. Erstes Teil ist die Stanby - Schaltung mit dem TNY253. Die zweite Schaltung mit dem L6598 ist für die normale Gerätefunktion - HF-Teil, NF-Teil, CD- Laufwerk.
Die Funktion ist wie beim ATX-Netzteil beim PC.

Wenn die Standby-Netzteilschaltung nicht arbeitet startet das gesamte Gerät nicht.
Die erste Prüfung sollte auf Untebrechungen (F2) und Kurzschlüsse in den Bauteile auf der Netzseite geschehen. Für diese Prüfung reicht ein ein Ohm- Meter aber vorher prüfen ob die beiden Elkos auf der Netzseite entladen sind.
Kandiaten für Kurzschlüsse sind der TNY253 und die Transistoren P6NB50.

Wenn bis dahin nichts auffällig ist wird ein Trenntrafo und eine Glühlampe 230V100W (in Reihe mit Schaltnetzteil) und eine Glühlampe 6V 0,3A (von Masse nach 5V- Standby (3) auf Ausgangseite Netzteil). Schaltnetzteil ist dabei vom Gerät getrennt. Ist der Trenntrafo ein Regeltrenntrafo ist dieser auf 200 - 220V einzustellen und dann das Schaltnetzteil mit 100W Glühlampe in reihe anzuschliessen. Ein langsames hochregeln der Netzspannung (von 0V bis 220V kann das Schaltnetzteil zerstören. Stehen die 5V - Standby an ist der Fehler in der restlichen Schaltung zu suchen wenn nicht dann ist der TNY253 defekt. Leuchtet die 100W - Glühlampe hell liegt ein Kurzschluss vor

 

 

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
30.Mar.17 16:31
Reply  |  You aren't logged in. (Guest)   4

Hallo Herr Tieke,

so ganz defekt ist das SMPS wohl doch nicht. Zwischendurch kommt noch Leben aus dem Teil. Ich habe einmal - ganz nach B&O On-site Service Guide - die Verbindung von Modul 2 zu Modul 1 getrennt und am Stecker 2P1 den Pin4 gegen den Pin12 OHNE Last gemessen. Die Gleichspannung hier beträgt ca. 5,12 Volt und hat kaum Oberwellen (Siehe Foto):

EDIT:

Was mich ein wenig verwundert ist, dass die Source des TNY253G nicht wie im Datenblatt geschrieben, am Emitter des Optokopplers liegt. Meine bisherigen Aufzeichnungen sehen wie folgt aus (bin noch lange nicht fertig):

Aufgrund einer PM von Herrn Stefan Hübner habe ich mir die Schaltung noch einmal genauer angesehen und festgestellt, dass sehrwohl die Source des TNY253G an Masse anliegt, wie auch der Emitter des Optokopplers. Also alles wie vorgeschrieben. Auf der Platine war das schwierig zu sehen, erst ein Nachmessen brachte die Erkenntnis. Dank an dieser Stelle nochmal an Herrn Hübner.

Meine Aufzeichnungen sehen nun so aus:

EDIT ENDE

Mit eingebautem Modul 2 kann es sein, dass die BeoSound 1 ganz normal betrieben werden kann. Aber nach einer gewissen Zeit (leider nicht reproduzierbar) sind Lautstärkeschwankungen zu hören und dann fällt die BeoSound 1 mit einem hörbaren Knacken (Knall) aus. Es erlischt auch die Standby Lampe.

Ich werde dann mal weiter suchen!

Danke für die Anregungen auch an Herrn Richter!

MfG M.Ruhe

This article was edited 02.Apr.17 11:20 by Michael Ruhe .

Georg Beckmann
Georg Beckmann
Editor
D  Articles: 412
Schem.: 15
Pict.: 3
31.Mar.17 16:47
Reply  |  You aren't logged in. (Guest)   5

Hallo Herr Ruhe,

 

hier können Sie das Datenblatt des TNY253 herunterladen.

TNY253

Die Fa. Powerintegrations stellt clevere SMP IC-s her, ich habe schon einige in Designs eingesetzt.
Es gibt auch App.notes darüber, dann ist die Rekonstruktion des aktuellen Plans einfacher.

Dort finden Sie auch die Erklärungen, wie das IC exakt funktioniert, so findet sich der Fehler besser.

 

MFG

Georg Beckmann

 

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
31.Mar.17 20:35
Reply  |  You aren't logged in. (Guest)   6

Hallo Herr Beckmann,

was ist mit "Es gibt auch App.notes darüber" gemeint? Damit kann ich leider nichts anfangen. Ich bräuchte hier noch ein wenig Information. Danke. 

Mit freundlichen Grüßen M.Ruhe

 

NACHTRAG: Habe die App.notes gefunden!

This article was edited 31.Mar.17 22:21 by Michael Ruhe .

Georg Beckmann
Georg Beckmann
Editor
D  Articles: 412
Schem.: 15
Pict.: 3
01.Apr.17 13:49

Count of Thanks: 1
Reply  |  You aren't logged in. (Guest)   7

Hallo Herr Ruhe,

 

Entschuldigung für den Denglish Slang,

unter App - note meinte ich Applikations Note, dh. Beispiele vom Hersteller über den Einsatz eines Bauteils.
App-note hier z.B. zum Download.

Eine kurze Erklärung der Funktion, welche für die Fehlersuche reichen sollte.

Das IC enthält einen Taktgeber, welcher mit einer Frequenz von 44kHz den Ausgang ( D) gegen Masse
(S) schaltet, falls folgende Bedingungen zutreffen:

- Enable (E) ist NICHT gegen Masse (S) geschaltet

- das IC ist NICHT überhitzt

- Der Maximalstrom ist NICHT erreicht.

Solange der Ausgang (D) eingeschaltet ist, steigt der Strom im Wandlertrafo linear an.

Wenn der Ausgang dann abschaltet, fliesst ein Strom entsprechend des Übersetzungsverhältnisses
auf der Sekunderärseite durch die Gleichrichterdiode und nimmt linear ab.

Sobald das IC das nächste Mal einschaltet, ist der Strom auf der Sekundärseite wieder null, der Vorgang wiederholt sich.

Wenn die Ausgangsspannung erreicht ist, wird über eine Rückkopplung mit Optokoppler oder anderen Methoden der Enable Eingang an Masse geschaltet. Dadurch schaltet das IC den Primärstrom aus oder je nach dem gar nicht erst ein.

Jetzt zur Fehlersuche: Ist vielleicht der Elko nach dem Gleichrichter taub ?
Dann würde das IC sofort ausschalten, weil die Ausgangsspannung schlagartig hochgeht.
Test: einfach neuen Elko parallel schalten.

Ist die Gleichrichterdiode durch ?

Test: Ohmmeter
 

Ist ein Kurzschluss am Ausgang ?

Test: Alle Last abklemmen.

Ist das IC defekt ?

Test: Ist der Enable Eingang frei ( nicht an Masse ). ?

Liegt am D Ausgang des IC eine hohe Gleichspannung ( 200.. 300V ) und schaltet diese

mit ca. 44 kHz gegen Masse. Dazu wird ein Osci benötigt Vorsicht !!  Netzspannung. => Trenntrafo

Wenn Sie damit nicht weiterkommen, kann ich gerne helfen.

 

Mit freundlichen grüßen

 

Georg Beckmann
 

 

 

 

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
01.Apr.17 18:02
Reply  |  You aren't logged in. (Guest)   8

Hallo Herr Beckmann,

danke für die weiteren Informationen. Ich hatte letztlich die "app.notes" selber gefunden. Ein bißchen Nachdenken hat da geholfen ;). Inwieweit sich die Beispiele nutzen lassen, um den Fehler zu finden, muss ich noch prüfen. Im Datasheet des TNY253 sind ja auch Beispiele angegeben.

Nun zu Ihrer Mail:

Jetzt zur Fehlersuche: Ist vielleicht der Elko nach dem Gleichrichter taub ? Dann würde das IC sofort ausschalten, weil die Ausgangsspannung schlagartig hochgeht.
Test: einfach neuen Elko parallel schalten.

Sie meinen hier die beiden Elkos nach dem Brückgleichrichter?

Soweit ich das überprüfen konnte, sind die beiden Elkos intakt. Mein ESR Meter (ESR70 von PEAK) zeigt einen guten Serienwiderstand und auch eine entsprechende Kapazität.
 

Ist die Gleichrichterdiode durch ?

Welche ist gemeint? Der Brückengleichrichter arbeitet.

Ist ein Kurzschluss am Ausgang ?

Nein. Wie ich in einem der vorherigen Posts schrieb, arbeitet das SMPS zeitweise gut.

Ist das IC defekt ? Test: Ist der Enable Eingang frei ( nicht an Masse ). ?

Das TNY253G ist meiner Meinung nach vollkommen okay. Enable liegt NICHT an Masse.

Liegt am D Ausgang des IC eine hohe Gleichspannung ( 200.. 300V ) und schaltet diese mit ca. 44 kHz gegen Masse. Dazu wird ein Osci benötigt Vorsicht !!  Netzspannung. => Trenntrafo

Der Graph am Drain sieht bei mir so aus:

Vergleiche ich das mit dem Datenblatt bei "Light Load", dann sieht das ziemlich identisch aus:

Danke für die Anregungen. Ich suche weiter.

MfG M.Ruhe

Georg Beckmann
Georg Beckmann
Editor
D  Articles: 412
Schem.: 15
Pict.: 3
02.Apr.17 11:02
Reply  |  You aren't logged in. (Guest)   9

Jetzt ist die Fehlerursache schon klarer.

Der Mosfet schaltet offensichtlich sofort wieder aus.

Das kann lt. Funktionsbeschreibung des IC 3 Gründe haben.

- Das IC ist zu heiss.  -> auszuschliessen.

Die Spannung am Ausgang ist zu groß -> offensichtlich ist ja das Gegenteil der Fall.

Ein Kurzschluss am Ausgang -> Da müssen wir weitersuchen.

-Elko auf der Sekundärseite, Gleichrichterdiode auf der Sekundärseite, oder andere Bauteile
die einen Kurzschluss am Ausgang verursachen können.

Können Sie die Last am Ausgang einmal unterbrechen, so dass nur noch die Rückkopplung, die sekundäre Gleichrichterdiode und der ( die ) sekundären Elkos angeschlossen sind. ?

 ( Ob Elko oder Gleichrichterdiode einen Kurzschluss haben, können Sie ja auch prüfen. )

 

MFG

 

Georg Beckmann

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
02.Apr.17 11:35
Reply  |  You aren't logged in. (Guest)   10

Hallo Herr Beckmann,

Zitat:

Können Sie die Last am Ausgang einmal unterbrechen, so dass nur noch die Rückkopplung, die sekundäre Gleichrichterdiode und der ( die ) sekundären Elkos angeschlossen sind. ?

Zitatende

Die hier dargestellten Graphen sind ausschließlich OHNE Last produziert worden. Der letzte Screenshot wurde kurz nach Einschalten des Trenntrafos aufgenommen. Von einer Überhitzung ist hier auch meinerseits nicht auszugehen. Ich werde das IC heute aber nochmal daraufhin prüfen. Die Sekundärseite muss ich mir noch genauer ansehen. Ich habe den Schaltplan bislang nur für die Primärseite und hier auch nur den Standby Anteil nahezu komplett. Der Rest fehlt noch. Ist halt eine Menge Arbeit - die aber auch viel Spaß macht.

Danke für die Anregungen.

MfG M.Ruhe

NACHTRAG:

So nun habe ich eben einen Temperaturtest gemacht. Starttemperatur des IC war 22,7 Grad Celsius. Nach fünf Minuten Betriebszeit - ohne Last - ist die Temperatur des IC lediglich auf 24,0 Grad Celsius gestiegen.

This article was edited 02.Apr.17 11:53 by Michael Ruhe .

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
03.Apr.17 16:17

Count of Thanks: 1
Reply  |  You aren't logged in. (Guest)   11

Um hier noch einmal ganz sicher zu sein, habe ich nachstehend ein SMD Bauteil vom SMPS fotografiert. Meiner Meinung nach handelt es sich um eine ZENER Diode. Leider finde ich keinen exakten Bezug zum Hersteller bzw. ich weiß nicht genau, was für Werte dieses Bauteil haben muss.

Bitte einmal draufschauen:

Liege ich hier richtig oder handelt es sich doch um ein anderes Bauteil?

Danke ans Forum

MfG M.Ruhe

Giovanni Cucuzzella
 
Editor
D  Articles: 356
Schem.: 272
Pict.: 330
03.Apr.17 17:54
Reply  |  You aren't logged in. (Guest)   12

Hallo Herr Ruhe,

ein wenig Recherche im Netz hat folgendes zu Tage gebracht:

Der Hersteller der Diode ist laut aufgedrucktem Logo General Semiconductor - Vishay. Der Typ EGF1C (EC) und das Fertigungsdatum Februar 2012 (22) geht aus der Stempelung hervor.
Es handelt sich nicht um eine Zenerdiode sondern um eine sehr schnelle (Schalt-) Diode. Siehe dazu die angefügten PDF-Dateien.

Freundliche Grüße

Giovanni Cucuzzella

Attachments:

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
03.Apr.17 19:57
Reply  |  You aren't logged in. (Guest)   13

Hallo Herr Cucuzzella,

Herzlichen Dank für diese Recherche. Ich hatte es auch versucht, bin aber nicht fündig geworden. Die beiden PDFs sind Gold Wert. Danke!

MfG M.Ruhe

Michael Ruhe
Michael Ruhe
 
D  Articles: 12
Schem.:
Pict.: 9
06.May.17 13:51
Reply  |  You aren't logged in. (Guest)   14

Hier meine Erfolgsgeschichte von der Reparatur meines Schaltnetzteils der BeoSound 1.

Vielen Dank an dieser Stelle für die super Hinweise und speziell die großartige Unterstützung von Herrn Georg Beckmann!

Wie zu Beginn dieses Threads schon geschrieben, hat sich meine BeoSound 1 verabschiedet. Der Fehler wurde in der Spannungsversorgung vermutet, wo er letztendlich auch gefunden wurde. Von B&O gibt es für dieses Gerät kein Schaltbild und im Netz wurde ich auch nicht fündig. Also machte ich mich ans Werk und versuchte den Schaltplan anhand der mir vorliegenden Leiterplatte zu rekonstruieren. Da ich mit dem Hobby der Elektronik erst jetzt so richtig angefangen habe, war das für mich eine große Herausforderung, zumal es sich um eine Multilayerplatine handelt. Fertig geworden bin ich damit nicht, aber bis zum Erkennen des Fehlers hat es gereicht.

Um es kurz zu machen: Sämtliche von mir überprüfte Bauteile, ob in der Schaltung oder auch ausgelötet, wiesen keinerlei Fehler auf. Es stellte sich letztlich heraus, dass ein SMD Bauteil mit dem Marking Code 8A (ein MUN2211) mit seinem Pin 2 keine Verbindung zur Masse mehr hatte.

Vom Pin 2 dieses Bauteils endete eine Leiterbahn an einem Loch. Hier steckte eine Messingbuchse drin, die die Verbindung zur anderen Seite der Platine herstellen sollte um sich dort die notwendige Masse zu holen. Der Übergang von der Leiterbahn zur Messingbuchse war komplett weg korrodiert. An der Korrosionsstelle war Kupferoxid zu erkennen. Dies konnte ich erst mit Hilfe meines Auflichtmikroskops und nach Wegkratzen des Schutzlacks erkennen. Da die Buchse einen Innendurchmesser von gerade einmal 0,4 mm hatte, konnte ich einen dementsprechenden Draht durchstecken und von beiden Seiten verlöten. Das war alles.

Außer jeder Menge Zeit, ist halt ein Hobby, hat die Reparatur keinen einzigen Cent gekostet. Bei B&O wäre die gesamte Platine 2, also das gesamte Schaltnetzteil, als Modul getauscht worden. Was für eine Verschwendung!

Herzliche Grüße

M.Ruhe

This article was edited 06.May.17 13:54 by Michael Ruhe .

  
rmXorg