radiomuseum.org
Please click your language flag. Bitte Sprachflagge klicken.

telefunken: Info request about Telefunken 770 wkk device

Moderators:
Martin Renz Ernst Erb Vincent de Franco Martin Bösch Mark Hippenstiel Bernhard Nagel Dietmar Rudolph Otmar Jung Heribert Jung Eilert Menke 
 
Please click the blue info button to read more about this page.
Forum » Radios and other type of sets (Physics) etc. » MODELS DISPLAYED » telefunken: Info request about Telefunken 770 wkk device
           
Ion Carabas
Ion Carabas
 
RO  Articles: 38
Schem.: 6
Pict.: 90
10.Mar.21 09:24

Count of Thanks: 2
Reply  |  You aren't logged in. (Guest)   1 Dear colleagues, I need your help. Some time ago I started restoring a Telefunken 770 wkk device. I changed all the fixed capacitors and cleaned very well the block containing the wave switch. Finally I checked all the voltages on all the tubes. The results were 5-6% higher. I retuned the medium frequency transformers, the device works normally except for the EM11 tube which opens partially on a strong station Bucharest 1 and the brightness trembles not being stable. I measured the voltage on the grid and it is -1.5 volts, a bit small (EM11 tube is new!) I changed all the parts on the chain between the grid and the detection diode in EBF11. Moreover, I replaced the diodes in the tube with germanium diodes. Nothing has changed in the operation of EM11. My knowledge is limited, my profession is not electronic. I am waiting for your help and advice. With thanks, Ion Carabas
Tomasz Szczesniak
 
 
PL  Articles: 75
Schem.: 87
Pict.: 1173
10.Mar.21 16:29

Count of Thanks: 1
Reply  |  You aren't logged in. (Guest)   2

Hello.

 

First check DC voltage on detector diode (connected to 76 capacitor[1]). There should be negative voltage, the greater signal - the more negative voltage at this point. There should be -10V or more (nagative) for strong station. If this happen you shold all resistors and capacitors between EM11 grid and EBF11 diode (resistors 89, 87, 86, capacitor 93) for shorts and continuity.

In aces where there is no negative voltage on diode it means that HF signal incoming to diode is small. It can be caused by broken 76 capacitor, misaligned circuits (not only IF, also input filter and oscillator should be correctly adjusted, it is not easy for newbies) weak tubes (EBF11 and ECH11).

IF signal level for loud receiving could be relatvely small, not strong enough to drive the eye tube.

[1] Part numbers according to schematic uploaded on rm.org

Ion Carabas
Ion Carabas
 
RO  Articles: 38
Schem.: 6
Pict.: 90
16.Mar.21 08:13

Count of Thanks: 1
Reply  |  You aren't logged in. (Guest)   3 Dear Mr. Tomasz, I measured the voltage on the detection and it is -1.0 volts, very small. As you can see from the photo below, I changed almost all the variable capacities in the channel block. The original ones no longer work after 83 years from manufacture and we replaced them with variable air capacities. You are right that the oscillator circuits and input circuits were not tuned. As soon as I will tunned them, I will keep you informed if the magic eye works normally.

Attachments:

Ion Carabas
Ion Carabas
 
RO  Articles: 38
Schem.: 6
Pict.: 90
01.Apr.21 15:29
Reply  |  You aren't logged in. (Guest)   4 Dear Tomasz, Hello. Now I have documented how I can tune the local oscillator and the input circuits. But I have a problem that I don't know how to solve. For tuning the variable capacitors must be completely closed and the scale indicator needle positioned to the left of the scale towards the large fragments. When I turn the knob to open the variable capacitor, the needle goes a little to the left and locks. He has to go to the right. The rope mounted on the device is original and I do not understand what is happening. Can you help me with some advice?
Michael Watterson
 
Editor
IRL  Articles: 979
Schem.: 650
Pict.: 2497
04.Apr.21 16:07
Reply  |  You aren't logged in. (Guest)   5

The turns are in the wrong direction on the spindle with the knob?

  
rmXorg